Browser version compatibility

Browsers, like Chrome, Firefox and Opera are being constantly updated. These updates in browsers’ source codes can affect how Multiloginapp interacts with it. This means that some new browser versions may not properly work with Multiloginapp. This is due to the fact that we are only able to integrate Multiloginapp with the most recent browser versions after they are out.

During the past year, we have had countless issues with bugs in half-baked browser releases. Unless you want your hard work getting trashed by an untested browser auto-update, please disable automatic updates in every browser you are planning to use in Multiloginapp. Use this visual guide to disable auto-updates on your browsers.

The table below shows the compatibility of each versions of each browser with Multiloginapp 1.3.14. Hover on the version number to read comments and notes about that version.

  • Chrome
  • v51.0
    Works, but may crash on session start
  • v52.0
    Works, but may crash on low performance machines
  • v53.0
    Works, but may crash on low performance machines
  • v54.0
    Works, but flash may not work
  • Firefox
  • v46.0
    Works!
  • v47.0
    Works
  • v48.0
    Works!
  • v49.0
    Works!
  • v50.0
    Works
  • Opera
  • 40. 0
    Works!
  • 41. 0
    Frequently crashes and fails to spoof certain fingerprints
  • StealthFox
  • v49.0
    Works!